
<!DOCTYPE html>

<!--[if IE 8]> <html class="ie ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->

<head>


<meta charset="UTF-8" />
<title>Iron Fist Fends Off Iron Dog In Eight Round Slugfest | Island Sun</title>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="pingback" href="http://www.islandsun.com/xmlrpc.php" />
	

	

<!-- This site is optimized with the Yoast SEO plugin v3.0.7 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Iron Fist Fends Off Iron Dog In Eight Round Slugfest | Island Sun" />
<meta property="og:description" content="By Dean “The Sportsman” Greenaway Julan “Iron Fist” Brown knocked Jamaica’s Miguel “Iron Dog” Ray to the canvas several times during Saturday’s Clash of the Irons II, which unlike the first encounter lasted three rounds, this one turned into an eight rounds slugfest at the Multipurpose Sports Complex, but every time he went down, theRead More" />
<meta property="og:url" content="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/" />
<meta property="og:site_name" content="Island Sun" />
<meta property="article:section" content="Sports News" />
<meta property="article:published_time" content="2016-12-21T04:11:36+00:00" />
<meta property="article:modified_time" content="2016-12-21T04:11:54+00:00" />
<meta property="og:updated_time" content="2016-12-21T04:11:54+00:00" />
<meta property="og:image" content="http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Island Sun &raquo; Feed" href="http://www.islandsun.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Island Sun &raquo; Comments Feed" href="http://www.islandsun.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Island Sun &raquo; Iron Fist Fends Off Iron Dog In Eight Round Slugfest Comments Feed" href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.islandsun.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.4.5"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;return g&&g.fillText?(g.textBaseline="top",g.font="600 32px Arial","flag"===a?(g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3):"diversity"===a?(g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e):("simple"===a?g.fillText(h(55357,56835),0,0):g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.islandsun.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.1' type='text/css' media='all' />
<link rel='stylesheet' id='scrollup-css-css'  href='http://www.islandsun.com/wp-content/plugins/smooth-scroll-up/css/scrollup.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:400,600,700|Roboto+Slab' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-core-css'  href='http://www.islandsun.com/wp-content/themes/smart-mag/style.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-responsive-css'  href='http://www.islandsun.com/wp-content/themes/smart-mag/css/responsive.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='pretty-photo-css'  href='http://www.islandsun.com/wp-content/themes/smart-mag/css/prettyPhoto.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://www.islandsun.com/wp-content/themes/smart-mag/css/fontawesome/css/font-awesome.min.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css-css'  href='http://www.islandsun.com/?bunyad_custom_css=1&#038;ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css'  href='http://www.islandsun.com/wp-content/plugins/easy-table/themes/default/style.css?ver=1.6' type='text/css' media='all' />
<script type='text/javascript' src='http://www.islandsun.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/plugins/wp-retina-2x/js/picturefill.min.js?ver=3.0.1'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/themes/smart-mag/js/jquery.prettyPhoto.js?ver=4.4.5'></script>
<link rel='https://api.w.org/' href='http://www.islandsun.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.islandsun.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.islandsun.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.4.5" />
<link rel='shortlink' href='http://www.islandsun.com/?p=8422' />
<link rel="alternate" type="application/json+oembed" href="http://www.islandsun.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.islandsun.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F&#038;format=xml" />
	
<!--[if lt IE 9]>
<script src="http://www.islandsun.com/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->

</head>

<body class="single single-post postid-8422 single-format-standard page-builder right-sidebar full">
<meta name="google-site-verification" content="4GDtkeZeITGXHF-8JdgmagBm4t5SmvA2rKqHTeIxEHc" />

<script type="text/javascript">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-55497571-1', 'auto');
  ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
  ga('send', 'pageview');

</script>


<div class="main-wrap">

	<div class="top-bar">

		<div class="wrap">
			<section class="top-bar-content">
			
								<div class="trending-ticker">
					<span class="heading">Trending</span>

					<ul>
												
												
							<li><a href="http://www.islandsun.com/santa-spreads-christmas-cheer-at-final-family-christmas-sundays/" title="Santa Spreads Christmas Cheer At Final “Family Christmas Sundays”">Santa Spreads Christmas Cheer At Final “Family Christmas Sundays”</a></li>
						
												
							<li><a href="http://www.islandsun.com/stoby-overhaul-leaders-in-close-ring-of-fire-finish/" title="Stoby Overhaul Leaders In Close Ring Of Fire Finish">Stoby Overhaul Leaders In Close Ring Of Fire Finish</a></li>
						
												
							<li><a href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/" title="Iron Fist Fends Off Iron Dog In Eight Round Slugfest">Iron Fist Fends Off Iron Dog In Eight Round Slugfest</a></li>
						
												
							<li><a href="http://www.islandsun.com/zonta-club-makes-donation-fsn/" title="Zonta Club Makes Donation To Fsn">Zonta Club Makes Donation To Fsn</a></li>
						
												
							<li><a href="http://www.islandsun.com/bvi-red-cross-raffle-raises-20k/" title="BVI Red Cross Raffle Raises $20k">BVI Red Cross Raffle Raises $20k</a></li>
						
												
							<li><a href="http://www.islandsun.com/what-a-farce-hon-fraser-says-about-government/" title="“What A Farce”, Hon. Fraser Says About Government">“What A Farce”, Hon. Fraser Says About Government</a></li>
						
												
							<li><a href="http://www.islandsun.com/hit-run-driver-never-apprehended-walwyn-brewley-says/" title="Hit &#038; Run Driver Was Never Apprehended: Walwyn Brewley Says">Hit &#038; Run Driver Was Never Apprehended: Walwyn Brewley Says</a></li>
						
												
							<li><a href="http://www.islandsun.com/vip-chairman-calls-transparency-freedom-information-legislation/" title="VIP Chairman Calls For Transparency &#038; Freedom Of Information Legislation">VIP Chairman Calls For Transparency &#038; Freedom Of Information Legislation</a></li>
						
												
							<li><a href="http://www.islandsun.com/robbery-long-bush-superette-confirmed/" title="Robbery At Long Bush Superette Confirmed">Robbery At Long Bush Superette Confirmed</a></li>
						
												
							<li><a href="http://www.islandsun.com/community-bids-eternal-farewell-to-naomi-grigg/" title="Community Bids Eternal Farewell To Naomi Grigg">Community Bids Eternal Farewell To Naomi Grigg</a></li>
						
												
											</ul>
				</div>
				
				<div class="search">
					<form action="http://www.islandsun.com/" method="get">
						<input type="text" name="s" class="query" value="" placeholder="Search..." />
						<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
					</form>
				</div> <!-- .search -->

							<div class="textwidget"><ul class="social-icons">
	<li><a href="/?feed=rss2" class="icon fa fa-rss" title="RSS"><span class="visuallyhidden">RSS</span></a></li>
	<li><a href="http://facebook.com/username" class="icon fa fa-facebook" title="Facebook"><span class="visuallyhidden">Facebook</span></a></li>
	<li><a href="http://twitter.com/username" class="icon fa fa-twitter" title="Twitter"><span class="visuallyhidden">Twitter</span></a></li>
	<li><a href="link to your google+ profile" class="icon fa fa-google-plus" title="Google+"><span class="visuallyhidden">Google+</span></a></li>
	<li><a href="link to your linkedin profile" class="icon fa fa-linkedin" title="LinkedIn"><span class="visuallyhidden">LinkedIn</span></a></li>
</ul></div>
						
			</section>
		</div>
		
	</div>

	<div id="main-head" class="main-head">
		
		<div class="wrap">
		
			<header>
				<div class="title">
				
				<a href="http://www.islandsun.com/" title="Island Sun" rel="home">
									
					<img src="http://adwitdigital.com/islandsun/wp-content/uploads/2014/02/logo.png" class="logo-image" alt="Island Sun"  />
						 
								</a>
				
				</div>
				
				<div class="right">
					
				
					
			<div class="ads-widget">
			
				<img src="http://www.islandsun.com/wp-content/uploads/2014/02/728x90_1.jpg" alt="Leaderboard" />			
			</div>
		
				
						</div>
			</header>
			
			<nav class="navigation cf" data-sticky-nav="0">
				<div class="mobile"><a href="#" class="selected"><span class="text">Navigate</span><span class="current"></span> <i class="fa fa-bars"></i></a></div>
				
				<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-1873" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1873"><a title="Home" href="http://www.islandsun.com/">Home</a></li>
<li id="menu-item-1905" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1905"><a href="#">News</a>
<ul class="sub-menu">
	<li id="menu-item-1893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-24 menu-item-1893"><a href="http://www.islandsun.com/category/local-news/">Local News</a></li>
	<li id="menu-item-1894" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-cat-25 menu-item-1894"><a href="http://www.islandsun.com/category/sports-news/">Sports News</a></li>
	<li id="menu-item-1892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-26 menu-item-1892"><a href="http://www.islandsun.com/category/caribbean-news/">Caribbean News</a></li>
</ul>
</li>
<li id="menu-item-4005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-28 menu-item-4005"><a href="http://www.islandsun.com/category/feature/">Feature</a></li>
<li id="menu-item-4006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4006"><a href="http://www.islandsun.com/archives/">Archives</a></li>
<li id="menu-item-1904" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1904"><a href="http://www.islandsun.com/classifieds/">Classifieds</a></li>
<li id="menu-item-2053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2053"><a href="http://www.islandsun.com/subscriptions/">Subscriptions</a></li>
<li id="menu-item-1903" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1903"><a href="http://www.islandsun.com/advertising/">ADVERTISING</a></li>
<li id="menu-item-2120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2120"><a href="#">More</a>
<ul class="sub-menu">
	<li id="menu-item-2121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2121"><a href="http://www.islandsun.com/links/">Links</a></li>
	<li id="menu-item-2150" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-30 menu-item-2150"><a href="http://www.islandsun.com/category/books/">Books</a></li>
	<li id="menu-item-2138" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-29 menu-item-2138"><a href="http://www.islandsun.com/category/collectables/">Stamps &#038; Collectables</a></li>
	<li id="menu-item-1909" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1909"><a href="http://www.islandsun.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-7987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7987"><a href="http://www.islandsun.com/down-memory-lane/">Down Memory Lane</a></li>
</ul></div>			</nav>
			
		</div>
		
	</div>
	
	<div class="wrap">
		<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://www.islandsun.com/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="http://www.islandsun.com/category/sports-news/"><span itemprop="title">Sports News</span></a></span><span class="delim">&raquo;</span><span class="current">Iron Fist Fends Off Iron Dog In Eight Round Slugfest</span></div>	</div>

<div class="main wrap cf">
	<div class="row">
		<div class="col-8 main-content">
		
				
				
<article id="post-8422" class="post-8422 post type-post status-publish format-standard has-post-thumbnail category-sports-news" itemscope itemtype="http://schema.org/Article">

		
	<header class="post-header cf">

	
		<h1 class="post-title" itemprop="name">
		Iron Fist Fends Off Iron Dog In Eight Round Slugfest		</h1>
		
		<a href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
		
	</header><!-- .post-header -->
	
	<div class="post-meta">
		By <span class="reviewer" itemprop="author"><a href="http://www.islandsun.com/author/adwitac/" title="Posts by admin" rel="author">admin</a></span> 
		on		<span class="dtreviewed">
			<time class="value-datetime" datetime="2016-12-21T04:11:36+00:00" itemprop="datePublished">December 21, 2016</time>
		</span>
		
		&middot; <span class="cats"><a href="http://www.islandsun.com/category/sports-news/" rel="category tag">Sports News</a></span>
			
	</div>
	
	
	<div class="post-container cf">
	
		<div class="post-content-right">
			<div class="post-content description" itemprop="articleBody">
			
				<div id="attachment_8423" style="width: 310px" class="wp-caption alignleft"><a href="http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up.jpg" rel="attachment wp-att-8423"><img class="size-medium wp-image-8423" src="http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up-300x200.jpg" alt="Julan &quot;Iron Fist&quot; Brown, left and Miguel &quot;Iron Dog&quot; Ray, battled over eight rounds" width="300" height="200" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up-300x200.jpg 300w, http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up.jpg 702w, http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up-300x200@2x.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a><p class="wp-caption-text">Julan &#8220;Iron Fist&#8221; Brown, left and Miguel &#8220;Iron Dog&#8221; Ray, battled over eight rounds</p></div>
<p>By Dean “The Sportsman” Greenaway</p>
<p>Julan “Iron Fist” Brown knocked Jamaica’s Miguel “Iron Dog” Ray to the canvas several times during <span data-term="goog_1842897228">Saturday’s</span> Clash of the Irons II, which unlike the first encounter lasted three rounds, this one turned into an eight rounds slugfest at the Multipurpose Sports Complex, but every time he went down, the Iron Dog got up and kept fighting.</p>
<p>Ray who was on the canvas in five of the eight rounds, said he couldn’t just stop when Brown threw the hard punches at him. He said before leaving Jamaica, his son told him ‘get up daddy even if he gets you. He’s fast, I know he’s good and I read about him, but, he’s a champ before and the champ of BVI. Even if he does get you my dad, remember me and get up. Don’t stay down. Finish your eight rounds even if you don’t win, I’ll be proud for you to finish your eight rounds.’</p>
<p>“When he caught me and I was down, I could have really stayed down, but my son kept whispering in my ear, ‘get up get up,’” he said. “So I had to. I had a good corner. I lift my hat to him, but, I couldn’t just stop when he threw those hard punches at me.”</p>
<p>Brown, who was cut over his right eye by Ray and was examined by the ringside doctor didn’t plan for the fight to go the distance.</p>
<p>“I didn’t expect this fight to go eight rounds, I expected it to go one round,” Brown said. “I stopped him in the third round the last time and the referee felt sorry for him after he went down several times and stopped the fight, but he surprised me tonight. I expected him to go down and stay down, but the dude is tough—he’s really an Iron Dog. He caught me some good ones, but it’s the effective one that worked for me”</p>
<p>Ray who lost 68-79, 70-77 and 72-78, said he conditioned himself better this time around and was a little more focused.</p>
<p>“I had some good people in my corner giving me props on how to really approach him as a fighter. He’s really good. He’s fast and has some cheeky moves but I think I got some clean hard and cheeky punches on him that should have taken down a Lion,” Ray said. “But, the Dog still stood up and completed his eight rounds. It’s just to wait now for the next bout, whenever, whomever, wherever.”</p>
<p>Antigua and Barbuda had two, including Yakita Aska who narrowly missed qualifying for the summer Rio Olympic Games. Aska won his last outing here in August.</p>
<p>“Tonight was a little tougher, a stronger opponent, but I did what I had to do,” said Aska who took a decision over the BVI’s Andrew Lettsome Jr., in the super heavy weight division. “He gave me a little but of a run for the money. I love taking them out in the deep waters than finish him, but this one, he could swim. He’s a strong one and didn’t go that easy.”</p>
<p>It was Lettsome’s first fight after missing the August card. “This was a very good experience, both of us threw some powerful punches but I guess he landed the most,” he said. “I learn that I have to move a lot because I was a bit stiff.”</p>
<p>Antigua and Barbuda’s Karl Warner had a first round knock out over the BVI’s Camari Bowers. “Coming in, I knew he was young so I made the decision to let him get the experience and I was speaking to him,” Warner explained. “But, he started to get a little wild and crazy. I didn’t want to end it but in boxing, if you let someone to get wild and unorthodox, you will get hit with a lucky shot that you won’t be able to predict and that can be dangerous. I just gave him a sharp jab and he went down. However, it teaches him you cannot throw punches without having concern about what the other person is going to do.”</p>
<p>Bowers who came out aggressive said Warner is a professional. “I need a lot more training to get where he is today,” he stated.</p>
<p>The card opened with 12 year olds Omari Lee and Kavon Wheatley, with Lee getting the victory.</p>
<p>Niquan Todman bested Johan Marlinece in the second bout. Tevon Chalwell got a victory over Romario Morgan and Cecil Williams got a surprised victory over Kevin Chinnery.</p>
			
										
							</div><!-- .post-content -->
		</div>
		
	</div>
	
		
	<div class="post-share">
		<span class="text">Share.</span>
		
		<span class="share-links">
			
			<a href="http://twitter.com/home?status=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F" class="fa fa-twitter" title="Tweet It">
				<span class="visuallyhidden">Twitter</span></a>
				
			<a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F" class="fa fa-facebook" title="Share at Facebook">
				<span class="visuallyhidden">Facebook</span></a>
				
			<a href="http://plus.google.com/share?url=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F" class="fa fa-google-plus" title="Share at Google+">
				<span class="visuallyhidden">Google+</span></a>
				
			<a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F&amp;media=http%3A%2F%2Fwww.islandsun.com%2Fwp-content%2Fuploads%2F2016%2F12%2FSizing-up.jpg" class="fa fa-pinterest"
				title="Share at Pinterest">
				<span class="visuallyhidden">Pinterest</span></a>
				
			<a href="http://plus.google.com/share?url=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F" class="fa fa-linkedin" title="Share at LinkedIn">
				<span class="visuallyhidden">LinkedIn</span></a>
				
			<a href="http://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F&amp;name=Iron+Fist+Fends+Off+Iron+Dog+In+Eight+Round+Slugfest" class="fa fa-tumblr"
				title="Share at Tumblr">
				<span class="visuallyhidden">Tumblr</span></a>
				
			<a href="mailto:?subject=Iron+Fist+Fends+Off+Iron+Dog+In+Eight+Round+Slugfest&amp;body=http%3A%2F%2Fwww.islandsun.com%2Firon-fist-fends-off-iron-dog-in-eight-round-slugfest%2F" class="fa fa-envelope-o"
				title="Share via Email">
				<span class="visuallyhidden">Email</span></a>
			
		</span>
	</div>
	
			
</article>




<section class="related-posts">
	<h3 class="section-head">Related Posts</h3> 
	<ul class="highlights-box three-col related-posts">
	
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="http://www.islandsun.com/stoby-overhaul-leaders-in-close-ring-of-fire-finish/" title="Stoby Overhaul Leaders In Close Ring Of Fire Finish" class="image-link">
					<img width="214" height="140" src="http://www.islandsun.com/wp-content/uploads/2016/12/Stoby-Mays-1-1-214x140.jpg" class="image wp-post-image" alt="stoby-mays-1" title="Stoby Overhaul Leaders In Close Ring Of Fire Finish" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/Stoby-Mays-1-1-214x140.jpg 214w, http://www.islandsun.com/wp-content/uploads/2016/12/Stoby-Mays-1-1-214x140@2x.jpg 428w" sizes="(max-width: 214px) 100vw, 214px" />
									</a>
				
				<div class="meta">
					<time datetime="2016-12-21T04:29:14+00:00">December 21, 2016 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="http://www.islandsun.com/stoby-overhaul-leaders-in-close-ring-of-fire-finish/" title="Stoby Overhaul Leaders In Close Ring Of Fire Finish">Stoby Overhaul Leaders In Close Ring Of Fire Finish</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="http://www.islandsun.com/nba-authentic-experience-was-amazing-for-four-bvi-players/" title="NBA Authentic Experience Was ‘Amazing’ For Four BVI Players" class="image-link">
					<img width="214" height="140" src="http://www.islandsun.com/wp-content/uploads/2016/12/BVI-Players-214x140.jpg" class="image wp-post-image" alt="Natasha Melville, left, Mahkayla Pickering, Demoi Bradley, Omar Walker, Jason Edwin and Shauliqua Fahie, enjoyed an NBA Authentic Experience in New York" title="NBA Authentic Experience Was ‘Amazing’ For Four BVI Players" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/BVI-Players-214x140.jpg 214w, http://www.islandsun.com/wp-content/uploads/2016/12/BVI-Players-214x140@2x.jpg 428w" sizes="(max-width: 214px) 100vw, 214px" />
									</a>
				
				<div class="meta">
					<time datetime="2016-12-15T04:47:02+00:00">December 15, 2016 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="http://www.islandsun.com/nba-authentic-experience-was-amazing-for-four-bvi-players/" title="NBA Authentic Experience Was ‘Amazing’ For Four BVI Players">NBA Authentic Experience Was ‘Amazing’ For Four BVI Players</a></h2>
				
			</article>
		</li>
		
		
		<li class="highlights column one-third">
			
			<article>
					
				<a href="http://www.islandsun.com/iaaf-level-i-coaching-course-attract-16-track-and-field-coaches/" title="IAAF Level I Coaching Course Attract 16 Track And Field Coaches" class="image-link">
					<img width="214" height="140" src="http://www.islandsun.com/wp-content/uploads/2016/12/BVI-Coaches-Officials-214x140.jpg" class="image wp-post-image" alt="bvi-coaches-officials" title="IAAF Level I Coaching Course Attract 16 Track And Field Coaches" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/BVI-Coaches-Officials-214x140.jpg 214w, http://www.islandsun.com/wp-content/uploads/2016/12/BVI-Coaches-Officials-214x140@2x.jpg 428w" sizes="(max-width: 214px) 100vw, 214px" />
									</a>
				
				<div class="meta">
					<time datetime="2016-12-15T04:42:02+00:00">December 15, 2016 </time>
					
															
					<span class="comments"><i class="fa fa-comments-o"></i>
						0</span>	
					
				</div>
				
				<h2><a href="http://www.islandsun.com/iaaf-level-i-coaching-course-attract-16-track-and-field-coaches/" title="IAAF Level I Coaching Course Attract 16 Track And Field Coaches">IAAF Level I Coaching Course Attract 16 Track And Field Coaches</a></h2>
				
			</article>
		</li>
		
		</ul>
</section>

	
				
			
		</div>
		
				
		<aside class="col-4 sidebar">
			<ul>
			
			<li id="text-4" class="widget widget_text">			<div class="textwidget"><img style="padding-left: 10px;" src="http://www.islandsun.com/wp-content/uploads/2014/10/3dflagsdotcom_ukbvc_2fawm.gif"/> </div>
		</li>

		<li id="bunyad_ads_widget-7" class="widget bunyad-ad">		
					
			<div class="ads-widget">
			
				<img src="http://www.islandsun.com/wp-content/uploads/2016/12/holiday.jpg" alt="Wine" /> <br/><br>
<img src="http://www.islandsun.com/wp-content/uploads/2016/12/ITALIAN-WINE-AD.jpg" alt="Wine" />

			
			</div>
		
		</li>
		
		
		<li id="bunyad_ads_widget-6" class="widget bunyad-ad">		
					
			<div class="ads-widget">
			
				<img src="http://www.islandsun.com/wp-content/uploads/2014/02/300x600_1.jpg" alt="skyscraper" />			
			</div>
		
		</li>
		
		
		<li id="bunyad-tabbed-recent-widget-3" class="widget tabbed">
		<ul class="tabs-list">
		
						
			<li class="active">
				<a href="#" data-tab="recent-posts">Recent Posts</a>
			</li>
			
						
			<li class="">
				<a href="#" data-tab="popular-posts">Popular Posts</a>
			</li>
			
						
		</ul>
		
		<div class="tabs-data">
							
			<ul class="tab-posts active posts-list" id="recent-tab-recent-posts">
			
						
				
				<li>
				
					<a href="http://www.islandsun.com/santa-spreads-christmas-cheer-at-final-family-christmas-sundays/"><img width="110" height="96" src="http://www.islandsun.com/wp-content/uploads/2016/12/2016-santa_spreads_christmas_cheer_at_final_family_christmas_sundays-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="2016-santa_spreads_christmas_cheer_at_final_family_christmas_sundays" title="Santa Spreads Christmas Cheer At Final “Family Christmas Sundays”" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/2016-santa_spreads_christmas_cheer_at_final_family_christmas_sundays-110x96.jpg 110w, http://www.islandsun.com/wp-content/uploads/2016/12/2016-santa_spreads_christmas_cheer_at_final_family_christmas_sundays-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />
										
					</a>
					
					<div class="content">
					
						<time datetime="2016-12-21T04:34:00+00:00">December 21, 2016 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/santa-spreads-christmas-cheer-at-final-family-christmas-sundays/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://www.islandsun.com/santa-spreads-christmas-cheer-at-final-family-christmas-sundays/" title="Santa Spreads Christmas Cheer At Final “Family Christmas Sundays”">
							Santa Spreads Christmas Cheer At Final “Family Christmas Sundays”</a>
																	
					</div>
				
				</li>
				
				
				<li>
				
					<a href="http://www.islandsun.com/stoby-overhaul-leaders-in-close-ring-of-fire-finish/"><img width="110" height="96" src="http://www.islandsun.com/wp-content/uploads/2016/12/Stoby-Mays-1-1-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="stoby-mays-1" title="Stoby Overhaul Leaders In Close Ring Of Fire Finish" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/Stoby-Mays-1-1-110x96.jpg 110w, http://www.islandsun.com/wp-content/uploads/2016/12/Stoby-Mays-1-1-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />
										
					</a>
					
					<div class="content">
					
						<time datetime="2016-12-21T04:29:14+00:00">December 21, 2016 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/stoby-overhaul-leaders-in-close-ring-of-fire-finish/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://www.islandsun.com/stoby-overhaul-leaders-in-close-ring-of-fire-finish/" title="Stoby Overhaul Leaders In Close Ring Of Fire Finish">
							Stoby Overhaul Leaders In Close Ring Of Fire Finish</a>
																	
					</div>
				
				</li>
				
				
				<li>
				
					<a href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/"><img width="110" height="96" src="http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Julan &quot;Iron Fist&quot; Brown, left and Miguel &quot;Iron Dog&quot; Ray, battled over eight rounds" title="Iron Fist Fends Off Iron Dog In Eight Round Slugfest" srcset="http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up-110x96.jpg 110w, http://www.islandsun.com/wp-content/uploads/2016/12/Sizing-up-110x96@2x.jpg 220w" sizes="(max-width: 110px) 100vw, 110px" />
										
					</a>
					
					<div class="content">
					
						<time datetime="2016-12-21T04:11:36+00:00">December 21, 2016 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://www.islandsun.com/iron-fist-fends-off-iron-dog-in-eight-round-slugfest/" title="Iron Fist Fends Off Iron Dog In Eight Round Slugfest">
							Iron Fist Fends Off Iron Dog In Eight Round Slugfest</a>
																	
					</div>
				
				</li>
				
				
				<li>
				
					<a href="http://www.islandsun.com/zonta-club-makes-donation-fsn/">
										
					</a>
					
					<div class="content">
					
						<time datetime="2016-12-17T02:28:29+00:00">December 17, 2016 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/zonta-club-makes-donation-fsn/#respond"><i class="fa fa-comments-o"></i>
							0</a></span>
					
						<a href="http://www.islandsun.com/zonta-club-makes-donation-fsn/" title="Zonta Club Makes Donation To Fsn">
							Zonta Club Makes Donation To Fsn</a>
																	
					</div>
				
				</li>
				
								
							
			</ul>
							
			<ul class="tab-posts  posts-list" id="recent-tab-popular-posts">
			
						
				
				<li>
				
					<a href="http://www.islandsun.com/amended-computer-misuse-and-cybercrime-act-passed/">
										
					</a>
					
					<div class="content">
					
						<time datetime="2014-08-02T02:27:44+00:00">August 2, 2014 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/amended-computer-misuse-and-cybercrime-act-passed/#comments"><i class="fa fa-comments-o"></i>
							20</a></span>
					
						<a href="http://www.islandsun.com/amended-computer-misuse-and-cybercrime-act-passed/" title="Amended “Computer Misuse and Cybercrime” Act Passed">
							Amended “Computer Misuse and Cybercrime” Act Passed</a>
																	
					</div>
				
				</li>
				
				
				<li>
				
					<a href="http://www.islandsun.com/pirates-reds-whip-dominicanos-in-henley-softball-league/">
										
					</a>
					
					<div class="content">
					
						<time datetime="2014-04-11T07:13:36+00:00">April 11, 2014 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/pirates-reds-whip-dominicanos-in-henley-softball-league/#comments"><i class="fa fa-comments-o"></i>
							17</a></span>
					
						<a href="http://www.islandsun.com/pirates-reds-whip-dominicanos-in-henley-softball-league/" title="Pirates, Reds whip Dominicanos in Henley Softball League">
							Pirates, Reds whip Dominicanos in Henley Softball League</a>
																	
					</div>
				
				</li>
				
				
				<li>
				
					<a href="http://www.islandsun.com/territorys-senior-students-join-walwyn-at-7th-national-prayer-breakfast/"><img width="110" height="96" src="http://www.islandsun.com/wp-content/uploads/2014/05/PRAYER-BREAKFAST-2014-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="At the National Prayer Breakfast, students that made up the leadership of their schools and those that are registered for the highest number of CXC subjects were guests of Territorial Representative and Minister for Education, Culture and Youth Affairs, Hon Myron V. Walwyn." title="Territory’s Senior Students Join Walwyn At  7th National Prayer Breakfast" />
										
					</a>
					
					<div class="content">
					
						<time datetime="2014-05-09T09:37:01+00:00">May 9, 2014 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/territorys-senior-students-join-walwyn-at-7th-national-prayer-breakfast/#comments"><i class="fa fa-comments-o"></i>
							17</a></span>
					
						<a href="http://www.islandsun.com/territorys-senior-students-join-walwyn-at-7th-national-prayer-breakfast/" title="Territory’s Senior Students Join Walwyn At  7th National Prayer Breakfast">
							Territory’s Senior Students Join Walwyn At  7th National Prayer Breakfast</a>
																	
					</div>
				
				</li>
				
				
				<li>
				
					<a href="http://www.islandsun.com/hon-ralph-oneal-urged-to-publish-his-memoirs/">
										
					</a>
					
					<div class="content">
					
						<time datetime="2014-05-31T02:32:04+00:00">May 31, 2014 </time>
					
						<span class="comments"><a href="http://www.islandsun.com/hon-ralph-oneal-urged-to-publish-his-memoirs/#comments"><i class="fa fa-comments-o"></i>
							17</a></span>
					
						<a href="http://www.islandsun.com/hon-ralph-oneal-urged-to-publish-his-memoirs/" title="Hon. Ralph O’neal Urged To Publish His Memoirs">
							Hon. Ralph O’neal Urged To Publish His Memoirs</a>
																	
					</div>
				
				</li>
				
								
							
			</ul>
					
		</div>
		
		</li>
		
		
		<li id="bunyad_ads_widget-2" class="widget bunyad-ad">		
					
			<div class="ads-widget">
			
				<img src="http://www.islandsun.com/wp-content/uploads/2014/02/300x250_1.jpg" alt="Leaderboard" />			
			</div>
		
		</li>
		
		
		<li id="bunyad_ads_widget-5" class="widget bunyad-ad">		
					
			<div class="ads-widget">
			
				<img src="http://www.islandsun.com/wp-content/uploads/2014/02/300x250-11.jpg" alt="Rectangle" />			
			</div>
		
		</li>
		
			
			</ul>
		</aside>		
	</div> <!-- .row -->
</div> <!-- .main -->


	<footer class="main-footer">
	
		
	
			<div class="lower-foot">
			<div class="wrap">
		
						
			<div class="widgets">
							<div class="textwidget">Copyrighted © 2005 by SUN ENTERPRISES (B.V.I.) LTD. - PUBLISHERS OF THE ISLAND SUN Newspaper<br><br>
Powered by <a href="http://www.adwitdigital.com">Adwit Digital</>
</div>
		<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-2012" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2012"><a href="http://www.islandsun.com/contact-us/">Contact</a></li>
<li id="menu-item-2013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2013"><a href="#">Privacy</a></li>
<li id="menu-item-2014" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2014"><a href="#">About</a></li>
</ul></div>			</div>
			
					
			</div>
		</div>		
		
	</footer>
	
</div> <!-- .main-wrap -->

<script> var $nocnflct = jQuery.noConflict();
			$nocnflct(function () {
			    $nocnflct.scrollUp({
				scrollName: 'scrollUp', // Element ID
				scrollClass: 'scrollUp scrollup-tab scrollup-right', // Element Class
				scrollDistance: 300, // Distance from top/bottom before showing element (px)
				scrollFrom: 'top', // top or bottom
				scrollSpeed: 300, // Speed back to top (ms)
				easingType: 'linear', // Scroll to top easing (see http://easings.net/)
				animation: 'fade', // Fade, slide, none
				animationInSpeed: 200, // Animation in speed (ms)
				animationOutSpeed: 200, // Animation out speed (ms)
				scrollText: 'Scroll to top', // Text for element, can contain HTML
				scrollTitle: false, // Set a custom link title if required. Defaults to scrollText
				scrollImg: false, // Set true to use image
				activeOverlay: false, // Set CSS color to display scrollUp active point
				zIndex: 2147483647 // Z-Index for the overlay
			    });
			});</script><!-- WP-TopBar_5.33 :: DB: 5.08 :: Number of TopBars Selected: 0 :: Rotate TopBars: no -->
<script type='text/javascript' src='http://www.islandsun.com/wp-includes/js/comment-reply.min.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.islandsun.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.1'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/plugins/smooth-scroll-up/js/jquery.scrollUp.min.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/themes/smart-mag/js/bunyad-theme.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-content/themes/smart-mag/js/jquery.flexslider-min.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://www.islandsun.com/wp-includes/js/wp-embed.min.js?ver=4.4.5'></script>
<meta name="google-site-verification" content="4GDtkeZeITGXHF-8JdgmagBm4t5SmvA2rKqHTeIxEHc" />

<script type="text/javascript">
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-55497571-1', 'auto');
  ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
  ga('send', 'pageview');

</script>
</body>
</html>